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INTRODUCTION  

Methodical instructions for laboratory classes from the course "CAD of 

machines and tools" are intended for students of technical specialties of higher 

educational institutions who are studying in the specialty "Industrial mechanical 

engineering". 

The discipline "CAD of machines and tools" belongs to the cycle of pro-

fessional training, it is based on previous knowledge of fundamental and profes-

sionally oriented disciplines, in particular, such as "Metalworking equipment", 

"Machine parts", "Higher mathematics", " Fundamentals of CAD", etc. 

The task of the discipline is to acquaint students of the specialty with au-

tomated design systems (CAD) for their further use in solving design tasks, for 

example, in the design of machine tools and tools. Students should understand 

the general principles of construction and operation of CAD, as well as know the 

tools necessary for designing machines and tools. To acquire basic knowledge of 

the general principles of work and trends in the development of modern systems 

of automated design with the help of computer technology; to be able to use the 

most common domestic and foreign CAD systems. 



4 

History about the Delcam software 

Delcam was founded in 1977 on the Cambridge University site. In 1997, 

the company became a joint-stock company, and its constant development is due 

to the demand for software. Currently, the company is the largest developer of 

software for modeling and production of products. Delcam software is used by 

more than 45,000 organizations in more than 80 countries around the world. 

The Delcam company is one of the world's leading manufacturers of pro-

gressive CAD/CAM solutions for the manufacturing industry. Delcam's soft-

ware covers all areas of production, from modeling to precision control of the 

finished product, providing fully automated CAD/CAM solutions to support and 

ensure concept-to-reality. 

One of the main representatives of the Delcam software is the Pow-

erShape package - a modern modeling package with solid and surface modeling. 

Surface modeling is the strongest point of the PowerShape package. The pack-

age automatically suggests the most appropriate way to build the surface. At the 

same time, the user at any stage has the opportunity to independently set the 

construction method and parameters he needs. 

Delcam PowerMill is a package for preparing high-performance control 

programs for CNC milling machines. It allows you to increase the productivity 

of the machines and, at the same time, achieve the highest quality in the manu-

facture of parts and equipment. Delcam PowerMill is traditionally considered 

the best system for preparing control programs for milling of products of com-

plex shape. 

Delcam PowerInspert is an accuracy control system using 3-coordinate 

control and measuring machines and manipulators. Combining the advantages of 

a wide range of capabilities and ease of use, it allows you to control complex de-

tails by comparing them with the original computer models created in the CAD 

system. Delcam PowerInspert allows you to control both complex free-form sur-

faces (showing the deviation of any measured points from the computer model) 
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and geometric elements of the correct shape, control equipment, scan prototypes 

to create computer models. 

Delcam ArtCAM is a software package for spatial modeling and mechan-

ical processing, which allows you to automatically generate spatial models from 

a flat drawing and obtain products based on them on CNC machines. ArtCAM 

offers a powerful, easy-to-use set of modeling tools that gives the designer the 

freedom to create complex spatial reliefs. 

A powerful representative of the Delcam family of software products is 

the FeatureCAM system. This is a system for preparing control programs based 

on automatic recognition of typical elements. The technology of automatic 

recognition of processing elements has become extremely popular among cus-

tomers of small and medium-sized businesses, allowing to make the develop-

ment of programs for CNC machines as fast and simple as possible. 

The Delcam software line includes a specialized solution for the shoe in-

dustry - Delcam Crispin, which allows you to solve the design, decoration and 

manufacturing tasks of all types of shoes. Delcam also offers a specialized solu-

tion for dentists. This solution is based on an open system consisting of two 

modules. Delcam DentCAD is a specialized system for modeling dental bridges 

and crowns. Delcam DentMill is a specialized system for manufacturing dental 

bridges and crowns on CNC machines. 

FeatureCAM comprises several modules, which enable you to perform 

different functions. This help file documents the entire product family, so, to dif-

ferentiate between the features specific to individual products, the titles of help 

topic titles are followed by product codes in parentheses. The codes are: 

(25D) – requires a minimum of the 2.5D Milling product. 

(3D LITE) – Requires a minimum of the 3D Lite product. The functionali-

ty is also available in the 3D MX and 3D HSM products. 3D Lite is an entry-

level 3D product, which enables you to mill only one surface per feature, but 

you can create multiple features. The strategies available in 3D Lite are Z-level 

rough, Parallel rough, Parallel finish, Isoline, and 2D spiral. 
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(3D MX) – Requires a minimum of the 3D MX product. The functionality 

is also available in the 3D HSM product. 3D MX is a mid-level 3D product that 

enables you mill multiple surfaces. It has the same strategies as 3D Lite, plus Z-

level finish, Radial finish, Flowline finish, Four-axis finish, Horizontal + verti-

cal, Between curves, and Swarf milling. 

(3D HSM) – Requires a minimum of the 3D HSM product. 3D HSM is a 

high speed machining product with the same strategies as 3D MX, plus Pencil, 

Plunge roughing, Remachine, Steep and Shallow, and Spiral 3D. 

(REC) – Requires the FeatureRECOGNITION product. 

(MSIM) – Requires the Machine Simulation product. 

(5AP) – Requires the 5-axis Positioning product. 

(5AS) – Requires the 5-axis Simultaneous product. 

(TURN) – Requires the Turning product. 

(TURNMILL) – Requires the Turn/Mill product. 

(WIRE) – Requires the Wire EDM product. 

(TOMB) – Requires the Tombstone product. 

(SOLID) – Requires the Solid Modeling product. 

(MTT) – Requires the Advanced Turn/Mill (MTT) (Multi-turret turning) 

product. 

(SND) – Requires the shared Network Database product. 
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LABORATORY LESSON №1 

TURNING IN DELCAM FEATURECAM 

1.1 Goal 

Familiarize yourself with the capabilities of the DELCAM FeatureCAM 

system. Learn to create control programs for turning parts. 

1.2 Brief theoretical information 

1.2.1 The general interface of the DELCAM FeatureCAM program 

The FeatureCAM interface contains a number of standard Windows ele-

ments, such as toolbars, dialogs, context menus, and wizards. 

 

Рисунок 1.1. – Загальний вигляд робочого вікна FeatureCAM 

1 – Title bar displays the type of part setup in round brackets, in this case 

(Milling), and the name of your part file in square brackets, in this case [FM1]. 

When you have any unsaved changes in your part file, an asterisk (*) is dis-

played next to its name; 
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2 – Menu bar provides access to a number of menus. Selecting a menu, 

such as View, opens a list of associated commands and sub-menus. Sub-menus 

are indicated by a small arrow to the right of the text. For example, selecting 

View > Principal Views displays a list of commonly used views; 

3 – Toolbars provide quick access to the most commonly used commands 

in FeatureCAM; 

4 – The graphics window is the main working area; 

5 – Toolbox window with the Steps panel, Part View panel, and Browser. 

The Steps panel contains an ordered list of steps for creating part programs. 

Each step is a wizard that presents a series of dialogs for each process. They are 

listed in the order in which you should use them during the process of creating a 

part program. The Part View panel provides a hierarchical view of the part. The 

Browser contains information on the latest features available in FeatureCAM, 

including example files that you can load straight into FeatureCAM; 

6 – Results window contains the automatically generated documentation 

including tooling lists, setup sheets, and the NC part programs. Selecting one of 

the tabs at the bottom of the window changes the content of this window; 

7 – Assistance bar displays help for the current command; 

8 – Feature/Geometry Edit bar lets you select and edit a feature, or enter 

the point locations and parameters for geometry creation; 

9 – Status bar shows your current drawing units, tool crib, and post pro-

cessor settings, as well as your keyboard status and information about the simu-

lation when you run one. 

As in other Windows programs, in FeatureCAM you can call the neces-

sary command in several ways: 

− select the button on the toolbar; 

− select an option from the menu; 

− select an option from the context menu; 

− press the quick call key. 
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The right mouse button opens a context menu. The menu changes depend-

ing on where you are in the program. Common commands and functions that are 

applicable in this area may also be available. 

1.2.1. Panel "Part view" 

 

Figure 1.2 – Panel "Part view" 

The Part View toolbox provides a hierarchical view of the part. Each set-

up is listed with each of the feature of the setup listed underneath. From this 

view you can select, show, hide or modify features. To navigate the part view: 

1. If an object has a “+” in its left margin, click it to expand the view to 

reveal objects that are subordinate. Click on the ”-“ to collapse the view and 

hide the subordinate objects. Double clicking on the object also performs the 

same function. 

2. Clicking on object in the tree view will select the object in the graphics 

window. This selection method is good for distinguishing between overlapping 

objects in the graphics window. Make sure you click on the name and not the 

check box. See item 4 below. 

3. Clicking on an object also reveals the  button for that feature. Click-

ing on this button brings up menu of actions you can perform on the object. The 
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actions available are dependent on the object type. Right clicking on the object 

in the tree view also reveals this menu. 

We will get acquainted with the main capabilities of the system and the 

features of using commands using the example of creating a typical part. 

1.3 An example of creating a typical turning part 

This tutorial shows you how to create a simple turning part, generate tool-

paths and output the toolpaths used to machine the part. 

1.3.1. Starting FeatureCAM for the first time 

1. From the Start menu, select All Programs > FeatureCAM > Fea-

tureCAM. 

✓ You can also start the program by double-clicking the FeatureCAM  

icon on your desktop. 

The first time you start FeatureCAM, it runs a program to create the tools 

and materials database. 

2. Click OK to begin the configuration. This displays the Tool and Mate-

rial Setup dialog. 

 

3. To create a local database, select On my local computer. 
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If you want multiple computers to share the same tool and material infor-

mation:  

− Select On another computer that I will access over a network. 

− Click the Browse button, and use the Database Location dialog to se-

lect the folder where the database is located. 

✓ You need to create a database folder on your network first, and then copy 

an empty MDB database from the FeatureCAM CD-ROM to this location. 

The default database is created by MS Access, and should be accessed us-

ing the MS Jet database driver. You may use a different database type, 

such as MS SQL Server. For more information, refer to the online help. 

✓ You need to have the Shared Network Database module to use this option. 

4. Click Next. 

5. Choose the tools to load: 

 

Inch - loads only the inch tools 

 Metric - loads only the metric tools. 

Both - loads both inch and metric tools.. 

6. Click Next. 

7. If you chose to load both tool types, you are asked which tool type you 

use more often. Select Inch or Metric, and click Next. 
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8. Click Finish to initialize the database. 

✓ The tools database specifies the set of tools used by FeatureCAM to per-

form manufacturing operations. For best results, use the Tool Manager 

(available from the Manufacturing menu) to customize the database to re-

flect the tools in your shop. 

1.3.2. Creating a new file 

1. Starting FeatureCAM displays the New Part Document wizard. 

 

1. If the New Part Document wizard is not displayed, select the File > 

New menu option. 

2. Select New file in the New Part Document Wizard, and click Next. Se-

lect a Milling Setup. 
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3. Select the Unit of Measure (Inch or Millimeter). 

✓ You can change the default dimension units later, by selecting Options > 

File Options from the menu. 

4. Click Finish. 

1.3.3. Defining the stock 

The stock is the initial material from which you cut your part. By default, 

the Stock wizard (Dimensions page) opens on the screen as soon as you create a 

new part. It enables you to set the shape and dimensions for the stock, the stock 

material, part program zero, and the coordinate system for modeling. 

1. On the Dimensions page of the Stock wizard: 
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− Enter an OD (outside diameter) of 100 mm. 

− Enter a Length of 125 mm. 

− Enter an ID (inside diameter) of 0 mm. 

− From the Finish menu button select the Finish and Edit Properties op-

tion. 

 

This displays the Stock Properties dialog. 

2. In the Stock Properties dialog enter a Z of 0.0625 (1.5 mm), and click 

OK. 
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1.3.4. Preparatory steps 

The preparatory steps determine the coordinate system and tool crib. 

1. Select Options > Turning Input Modes > 3D (XYZ) from the menu to 

enable you to enter coordinates as X, Y, and Z values. 

2. Select Manufacturing > Set Tool Crib from the menu to display the Se-

lect Active Tool Crib dialog. 

3. Select the tools option from the Crib List, and click OK. 

4. To display the complete part: 

− Click the Rotate View , menu button to display the View menu: 
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− Click Center All . 

 

1.3.5Defining the geometry 

This shows you how to design your part. 

 

1. Draw two lines: 

− Click the Geometry  step in the Steps panel. This displays the 

Geometry Constructors dialog. 
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− Select the Create more than 1 option, and click the Line from two 

points  button. This displays the Feature/Geometry Edit bar.  

 

− Create two lines that define the outer profile, in the Feature/Geometry 

Edit bar:  

For point 1, enter an XYZ 1 of X 2 (50 mm), Y 0, Z -3.5 (-88 mm). 

For point 2, enter an XYZ 2 of X 1 (25 mm), Y 0, Z -3.5 (-88 mm). 

Press Enter. This draws a line in the graphics window. 

 

− Create a second line: 

For point 1 enter an XYZ 1 of X 1 (25 mm), Y 0, Z -3.5 (-88 mm). 

For point 2 enter an XYZ 2 of X 1 (25 mm), Y 0, Z 0. 

Press Enter to create a second line. 
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2. Create a chamfer to trim your lines. 

Click the Geometry  step in the Steps panel. 

− In the Geometry Constructors dialog, in the list of Fillet options click 

the Chamfer  button. 

− In the Feature/Geometry Edit bar, enter: 

− A width of 0.25 (6 mm).  

− A height of 0.25 (6 mm). 

− Position your mouse pointer close to the chamfer location. The cham-

fer snaps into place. 

 

− Click to place the chamfer on your drawing. The chamfer automatical-

ly trims your lines. 

3. To turn the part you need to convert these three individual lines into a 

single curve (chain the curve). 

− Select the Curves  step from the Steps panel. 

− In the Curves Creation dialog, select the Pick Curve Pieces  but-

ton. 

− In the graphics window, click locations 1, 2 and 3. Each line segment 

changes color when selected. 
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− In the Feature/Geometry Edit bar, name the curve turn, and press En-

ter. 

4. Create third line which you will use to create a Bore feature. 

− Click the Geometry  step in the Steps panel. 

− In the Geometry Constructors dialog, click the Line from two points 

 button. 

− In the Feature/Geometry Edit bar: 

− For point 1 enter an XYZ 1 of X 0.625 (16 mm), Y 0, Z 0. 

− For point 2 enter an XYZ 2 of X 0.625 (16 mm), Y 0, Z -3.75 (-94 

mm). 

− Press Enter. 

5. To chain the bore curve: 

− Select the Curves  step from the Steps panel.  

− In the Curves Creation dialog, select the Pick Curve Pieces  but-

ton. 

− In the graphics window, click locations 4 and 5 (you select the same 

line twice). 

 

In the Feature/Geometry Edit bar, name the curve bore, and press Enter. 

1.3.6. Creating the features 

This shows you how to create the turning features. 
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1. Select the 2D Turned Profiles  button, on the Display Mode toolbar, 

to switch to a simplified 2D representation of the part. 

 

✓ To open the Display Mode toolbar, select the View > Toolbars menu op-

tion, select the Display Mode option, then click OK. 

2. Create a Turn feature. 

− Click the Features  step in the Steps panel. 

− If you have the Turn/Mill module, the New Feature wizard asks you 

which type of feature you want to create. Select the Turning option, and click 

Next. 

 

− Select Turn in the From Curve section, and click Next. 

− In the Curve field select turn from the list. 
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Click the Pick Curve  button to select the curve graphically. The dialog 

minimizes to reveal the graphics window beneath. 

Click the curve you named turn earlier. 

In this particular case, two objects are available for selection: a line and a 

curve. Whenever your selection needs to be clarified, FeatureCAM opens the 

Select dialog. 

In the Select dialog, select turn, and click OK. 

− From the Finish menu button, select the Finish and Create More op-

tion to continue creating features. 
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3. Create a Face feature. 

− In the New Feature wizard, select the Turning option, and click Next. 

− In the From Dimensions frame, select Face, and click Next. 

− On the Dimensions page: 

Enter a Thickness of 0.0625 (1.5 mm). 

Enter an Outer Diameter of 4 (100 mm). 

Enter an Inner Diameter of 0. 

Click Next. 

− Click Finish and Create More. 

4. Create a Hole feature. 

− In the New Feature wizard, select the Turning option, and click Next. 

− In the From Dimensions frame, select Hole, and click Next. 

− On the Dimensions page: 

Enter a Depth of 3.75 (94 mm). 

Enter a Diameter of 1.0 (24 mm). 

Click Next. 

− On the Location page enter a Z of 0. 

− Click Finish and Create More. 

 

5. Create a Bore feature by using the same process you used to create the 

Turn feature. Use the curve named Bore. 



23 

 

6. Create a Groove feature. 

− In the New Feature wizard, select the Turning option, and click Next. 

− In the From Dimensions frame select Groove, and click Next. 

− On the Dimensions page: 

Select a Location of ID. 

Select an Orientation of X axis. 

Enter a Diameter of 1.25 (31 mm). 

Enter a Depth of 0.125 (3 mm). 

Enter a Width of 0.25 (6 mm). 

Leave the other settings at 0. 

Click Next. 

− On the Location page enter a Z of -3 (-75 mm). 

− Click Finish and Create More. 

 

7. Create a Thread feature. 

− In the New Feature wizard, select the Turning option, and click Next. 

− In the From Dimensions frame, select Thread, and click Next. 

− On the Dimension page: 
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Select Get the thread dimensions from a standard thread. Select OD. 

In the Designation field select the 2.0000- 4.5 UNC (M50-15 for metric). 

Click Next. 

− On the Dimensions page: 

Select a Thread of Right hand. 

Enter a Thread Length of 1.0 (24 mm). 

Click Next. 

− Click Finish and Create More. 

 

8. Create a Cutoff feature. 

− In the New Feature wizard, select the Turning option, and click Next. 

− In the From Dimensions frame select Cutoff, and click Next. 

On the Dimensions page: 

Enter a Diameter of 4 (100 mm). 

Enter an Inner Diameter of 0. 

Enter a Width of 0.122 (3 mm). 

Click Next. 

− On the Location page enter a Z of –4.5 (–112 mm). 

− Click Finish. 
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1.3.7. Viewing the part 

To look at the part in a different orientation you can select one of the 

standard predefined views. These options are available from the Standard 

toolbar: 

 

1. To return to a 3D view of the model, click the 2D Turned Profiles  

button, on the Display Mode toolbar. 

2. Click the Isometric View  button on the Standard toolbar. 

 

3. Shade the part. 

− Open the Part View panel, and select bore1 under the Setup1 node. 

− Click the Shade Selected  button on the Display Mode toolbar. 

− Select thread1 in the Part View panel. 
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− Click the Shade Selected  button again. 

 

4. Click the Unshade All  button on the Display Mode toolbar to return 

to the wireframe view. 

1.3.8. Simulating the toolpaths 

Now you have created the features, FeatureCAM automatically: 

− Selects the most appropriate tools and operations; 

− Recommends machining strategies; 

− Calculates speeds and feeds; 

− Generates toolpaths and creates the NC code. 

To view the simulated toolpath: 

1. Click the Toolpaths  step in the Steps panel todisplay the Simula-

tion toolbar. 

 

2. On the Simulation toolbar, select the 3D Simulation , option, and 

then click Play  to start the simulation. If the Automatic Ordering Options di-

alog displays, click OK to close it. This accepts the default ordering options. 

This displays a solid 3D rendering of the cutting process. By default, the 

3/4 view is shown when cutting or drilling the ID of the part. 
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✓ If the 3/4 view is not displayed, select Options > Simulation > Round 

Stock from the menu, select the 3/4 view with lathe ID work option, then 

click OK to close the dialog. Click the Play  button on the Simulation 

toolbar to see the changes. 

3. Click the Play to Next Operation . button. This displays the face op-

eration. 

4. Repeat step 3 to view each operation until the whole part is cut. 

5. Click Eject . This removes the simulation. 

1.3.9. Order of manufacturing operations 

 

The Op List tab in the Results window shows all of the operations needed 

to machine the features. A yellow warning sign next to an operation indicates a 
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potential problem with that operation. In this case, if you see any warnings ig-

nore them. 

You can control the automatic ordering of operations by using either rules 

or operation templates. We will consider this question in more detail in laborato-

ry work №3. 

This section changes the automatic ordering by modifying the Turn Oper-

ation template. 

To modify the template 

1. Select the Automatic Ordering option on the Op List tab. This ensures 

the automatic ordering rules are applied to the operations. 

2. Change the automatic ordering to group together the operations which 

use the same tool. 

− Click the Ordering Options  button. 

− In the Automatic Ordering Options dialog, select Use template. 

 

− Click Edit template. 

3. Click Edit template. 
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− Select Rough OD Turn.  

− Click  until Rough OD Turn is below Finish ID Turn. 

− Click OK to close the Feature Order dialog. 

4. Click OK to close the Automatic Ordering Options dialog.  

5. Simulate the part. 

− Select the Toolpaths  step from the Steps panel. This displays the 

Simulation toolbar. 

− Click the 3D Simulation , button, and then click the Play  button 

to start the simulation. 

Notice that the OD roughing and finishing now happen after the hole is 

drilled. 

− Click the Stop , button when simulation is complete to exit simula-

tion mode. 

1.3.10. Part documentation (Turning) 

As well as simulating the manufacturing of the part, the simulation also 

generates complete tool and operations lists. The tools selected are based on 

your tool database. You can print all of this information for use as an operator's 

checklist. 
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1. Click the Details tab in the Results window to display the Manufactur-

ing Operations sheet. 

 

You can review this sheet using the scroll bars. 

2. Select the Tool List option at the top of the Details tab to show the 

Manufacturing Tool Detail sheet. It contains all of the tools used to create the 

part based on the tool crib you selected. 

✓ You can print this documentation from the File > Print menu option. 

1.3.11. Generating NC code (Turning) 

FeatureCAM generates the NC code to manufacture parts on a CNC ma-

chine. You can generate NC code after you have simulated the part, and there-

fore calculated the toolpaths. 

1. Select the NC Code  step from the Steps panel. This displays the 

NC Code dialog.  

2. Click the Display the NC Code  button to generate the NC code. 
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1.3.12. Changing the post processor 

To change the post processor: 

1. Choose Processing > Postprocessor from the menu. The Post-processor 

dialog will open.  

2. Select Manufacturing > Post Process from the menu. This displays the 

Post Options dialog. 

Click Browse to view available post processors. The default folder for 

posts is C:\Program Files\Delcam\FeatureCAM\Examples\Posts. 

3. Select your post processor and click Open. 

The new post processor is displayed in the CNC File field. 

4. Click OK to exit the Post Options dialog and use the new post proces-

sor; click Cancel to exit the dialog and keep the original post processor. 

5. Select the Toolpaths  step from the Steps panel. 

6. Run a simulation of the part to regenerate the NC code. 

1.3.13. Saving the NC code 

To save an NC program: 

1. Select the NC Code  step from the Steps panel. This displays the 

NC Code dialog. 

2. Click the Save NC  button in the NC Code dialog. 
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3. In the Save NC dialog, accept the default filename and folder, and click 

OK. 

 

1.4 Tasks for the laboratory session 

According to the individual option, in the Delcam FeatureCAM system, 

create the necessary turning elements, determine the list and sequence of opera-

tions, and generate the control program code for the CNC machine tool. 

The main goal of this task is to study the main commands of the "Geome-

try", "Curves", "Elements" and "Trajectories" toolbar. In the process of perform-

ing the work, the student must learn to create elementary contours and consider 

all possible turning elements and methods of their determination. Be able to set 

up simulation of part processing and generate control program code. 

Variants of tasks are given in Appendix A, p. 90. 



33 

1.5 Requirements for a report on the performance of a laboratory 

session 

The report should contain the following sections: 

1. Topic and purpose. 

2. Individual task. 

3. Development of the control program for turning: 

− appearance and dimensions of the workpiece; 

− elements and contours for generating the control program; 

− operations and their main characteristics; 

− control program code; 

− part model. 

4. Conclusions from the laboratory session. 

1.6 Control questions 

1. Describe the main elements of the DELCAM FeatureCAM interface. 

2. Tool database. Methods of creating and using a database at one or more 

workplaces. 

3. Determine the methods of entering coordinates when constructing ge-

ometric primitives, pay attention to the peculiarities of using each of the meth-

ods. 

4. Describe the commands available on the Geometry toolbar and how to 

use them. 

5. Options for creating path elements, list the possible elements for a turn-

ing operation. 

6. Postprocessor - tasks and choices. 
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LABORATORY LESSON №2 

TURNING AND MILLING IN DELCAM FEATURECAM 

2.1 Goal 

Explore the capabilities of the DELCAM FeatureCAM system when 

combining turning and milling operations. Learn to create control programs for 

turning and milling single parts in one facility. 

2.2 An example of creating a typical turning-milling part 

This example introduces students to the creation of parts for lathes with 

the possibility of milling. Methods of combining turning and milling operations 

and creating milling elements on the end of the part and the outer diameter. 

Entering the system and setting the initial parameters is carried out ac-

cording to the method given in laboratory work No. 1, however, as the type of 

processing, you must select Turning/Milling, the units of measurement are inch-

es. 

2.2.1. Preparatory steps 

The preparatory steps define the stock and determine the coordinate sys-

tem and view. 

1. On the Dimensions page of the Stock wizard: 
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Select a shape of Round. 

− Enter an OD (outside diameter) of 3. 

− Enter a Length of 2. 

− Enter an ID (inside diameter) of 0. 

− From the Finish menu, select the Finish button. 

2. From the View  menu select Center All .  

3. Select Options > Turning Input Modes > Diameter (DZ) from the menu 

to enter coordinates as Diameter and Z values. 

2.2.2. Defining the geometry 

This shows you how to design your part. 

 

1. Draw three lines:  

− Select the Geometry  step from the Steps panel. This displays the 

Geometry Constructors dialog. 
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Select the Create more than 1 option, and click the Connected Lines  

button. This displays the Feature/Geometry Edit bar. 

− To create two lines that define the outer profile, in the Fea-

ture/Geometry Edit bar: 

For point 1 enter a D/Z 1 of D 2.5, Z 0. 

For point 2 enter a D/Z 2 of D 2.5, Z -1.5. 

Press Enter to create a line. 

− Create a second line with the values: 

For point 2 enter a D/Z 2 of D 2.75, Z -1.5. 

Press Enter to create a second line. 

− Create a third line with the values:   

For point 2 enter a D/Z 2 of D 2.75, Z -2. 

Press Enter to create a third line. 
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2. Create a Fillet to trim your lines. 

− Select the Geometry  step from the Steps panel. 

− In the Geometry Constructors dialog, in the list of Fillet options click 

the Corner Fillet  button. 

− In the Feature/Geometry Edit bar, enter a radius (R) of 0.125. 

− Position your mouse pointer in the corner between the first and second 

lines, and click to create the fillet. The fillet automatically trims your lines. 

 

3. To turn the part you need to chain the curves. 

− Select the Curves  step from the Steps panel. 

− In the Curves Creation dialog, select the Pick Curve Pieces  but-

ton. 

− In the graphics window, click the first line and then the third line. 

− In the Feature/Geometry Edit bar, name the curve Turn, and press En-

ter.  
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2.2.3. Creating the features 

This example shows you how to create the turning features. 

 

1. Click the 2D Turned Profiles  utton, on the Display Mode toolbar, to 

switch to a 3D representation of the part. 

2. Create a Turn feature. 

 

− Click the Features  step in the Steps panel. 

− In the New Feature wizard, select the Turning option, and click Next. 

− Select Turn in the From Curve section, and click Next.  

− In the Curve field select turn from the list. 

Click the Pick Curve  button to select the curve graphically. The dialog 

minimizes to reveal the graphics window beneath. 

Click the curve you named Turn earlier. 

In the Select dialog, select turn, and click OK. 
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− Click Finish. 

2.2.4. Viewing the part 

1. On the Standard toolbar select the Isometric View  button. 

 

✓ If this displays a 2D representation of the part, click the 2D Turned Pro-

files  button, on the Display Mode toolbar. 

2. Shade the part: 

− Open the Part View panel, and select turn1 under the Setup1 node. 

− Click the Shade Selected  button on the Display Mode toolbar. 

 

− Click the Unshade All  button on the Display Mode toolbar to re-

turn to the wireframe view. 

3. To change the view to a top view; from the Principal View  menu 

button, click the Top  button. 

2.2.5. Creating three radial holes on the face 
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This shows you how to add three Holes to the part. 

 

1. To return to a 2D view of the model, click the 2D Turned Profiles  

utton, on the Display Mode toolbar. 

 

2. Create a Hole. 

− Click the Features  step in the Steps panel. 

− In the New Feature wizard, select the Turn/Mill option, and click 

Next. 

− In the From Dimensions field, select Hole and click Next. 

− In the Dimensions dialog: 

Enter a Chamfer of 0.0. 

Enter a Depth of 1.0. 

Enter a Diameter of 0.25. 

− Click Finish and Create More. 
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3. Create a Pattern from feature:  

In the New Feature wizard, select the Turn/Mill option, and click Next. 

− In the From Feature field, select Pattern, and click Next. 

− Select the hole you just created and click Next. 

− Select Radial in the setup XY plane, and click Next. 

− On the Pattern - Dimensions page:  

Enter a Number of 3.0. 

Enter a Diameter of 2.0. 

Enter a Spacing Angle of 120. 

Enter an Angle of 60. 

− Click Finish. 

− Click Cancel. 

4. View the 3D wireframe representation of the part: 

− Click the 2D Turned Profiles  button, on the Display Mode toolbar, 

to switch to a 3D representation of the part. 

− Click the Isometric View  button on the Standard toolbar. 

2.2.6. Engraving the face 

This shows you how to engrave the part by: 

− Creating the engraving text. 

− Creating a Groove feature. 
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1. Create a curve. 

− Select the Curves  step from the Steps panel. 

− In the Curves Creation dialog, select the Curve Wizard  button. 

− In the Curve wizard: 

 

Select Other methods as the construction method. 

Select Text as the constructor. 

Click Next. 

− On the Engraving Text page, configure the text properties. 
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Enter a Text of TURNMILL. 

Select a Path type of Linear. 

Enter a location of X 0.0, Y -0.045, Z 0.0. 

Enter an Angle of -90. 

From the Justification list, select Center. 

Enter a Scaling of X 0.4, Y 0.4. 

Click the Font button to display the Font dialog. 

From the Font list, select Machine Tool Gothic. 

Enter a Size of 72. 

Click OK to close the dialog. 

Click Finish to close the wizard. 

2. Create a Groove feature. 

− Select the TURNMILL text (curve1) in the graphics window. 

− Click the Features  step in the Steps panel. 

− In the New Feature wizard, select the Turn/Mill option, and click 

Next. 

− In the From Curve field, select Groove, and click Next. 

− On the Curve page, click Next (as you have selected the text).  

− On the Location page, click Next. 

− On the Dimensions page: 

Enter a Width of 0.0625. 

Enter a Depth of 0.02. 

Select Face. 

Select Simple (Engrave). 

− Click Finish. 
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2.2.7. Creating three slots 

This shows you how to add three milled slots to the part. 

 

1. Create a Slot feature: 

− Click the Features  step in the Steps panel. 

− In the New Feature wizard, select the Turn/Mill option, and click 

Next. 

− In the From Dimensions section, select Slot. 

− Select Make a pattern from this feature, and click Next. 

− On the Dimensions page: 

Enter a Length of 1.0. 

Enter a Width of 0.5. 

Enter a Depth of 0.25. 
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Click Next. 

− On the Patterns page select Radial around index axis, and click Next. 

− On the Location page: 

Enter a B Angle of 90. 

Enter a Radius of 1.25. 

Enter a Z to 0.25. 

Click Next. 

− On the Dimension page: 

Enter a Number of 3. 

Enter a Spacing Angle of 120. 

− Click Finish. 

2.8. Simulating the toolpaths 

To view the simulated toolpath: 

1. Click the Toolpaths  step in the Steps panel todisplay the Simula-

tion toolbar.. 

2. Click the 3D Simulation  button, and then click the Play  button 

to start the simulation. If the Automatic Ordering Options dialog displays, click 

OK to close it. This accepts the default ordering options. 

 

The toolpaths are accurately simulated including the part rotations. 
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✓ To simulate turning and milling paths, you must select a CNC file for a 

machine that supports turning with a driven tool, otherwise an error 

message will appear. 

3. Click Eject . This removes the Simulation toolbar. 

2.3 Tasks for the laboratory session 

According to the individual option, in the Delcam FeatureCAM system, 

create the necessary elements of turning and milling processing, determine the 

list and sequence of the operation, and generate the control program code for the 

workbench. 

The main goal of this task is to study additional commands of the "Geom-

etry", "Curves", "Elements" and "Trajectories" toolbar. In the process of per-

forming the work, the student must learn to more freely use the set of commands 

of the "Geometry" toolbar, create contours of various configurations with the 

help of the wizard. Be able to create milling elements and arrays based on them. 

Variants of tasks are given in Appendix B, p. 93. 

2.4 Requirements for a report on the performance of a laboratory 

session 

The report should contain the following sections: 

1. Topic and purpose. 

2. Individual task. 

3. Development of the turning and milling control program: 

− appearance and dimensions of the workpiece; 

− elements and contours for generating the control program; 

− operations and their main characteristics; 

− control program code; 

− part model. 

4. Conclusions from the laboratory session. 
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2.5 Control questions 

1. Methods of creating roundings and chamfers on the contour of the part. 

2. What milling elements can be created without creating a contour. 

3. Techniques for creating and arranging arrays of milling elements. 

4. Define the concept of contour. Justify the necessity of their creation. 

Types of contours, methods of their creation. 
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LABORATORY LESSON №3 

2.5D MILLING IN DELCAM FEATURECAM 

3.1 Goal 

Explore the possibilities of DELCAM FeatureCAM for creating elements 

of parts that are processed in the 2.5D-milling mode. Learn to create control 

programs. 

3.2 An example of creating a typical 2.5D milling part 

This example shows how to create several simple elements, generate the 

trajectories used to process the part and display them. And also explains the 

main principles and methods of managing the order of operations. 

Entering the system and setting the initial parameters is carried out ac-

cording to the method given in laboratory work No. 1, however, as the type of 

processing, you must select Milling operation, the units of measurement are mil-

limeters. 

3.2.1. Defining the Stock 

On the Dimensions page of the Stock wizard: 

 

− Enter a Thickness of 1 (25 mm). 

− Enter a Width of 4 (100 mm). 
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− Enter a Length of 5 (120 mm). 

− Click Finish. 

2. Click OK to accept the default values of the Stock wizard. 

3.2.2. Creating the features 

This step shows how to create Hole and Rectangular Pocket features. 

  

1. Create a Hole feature. 

− Click the Features  step in the Steps panel. 

− In the New Feature wizard, select Hole in the From Dimensions sec-

tion, and click Next. 

− Enter a Diameter of 0.5 (12 mm), and click Next. 

− Enter a hole center location of X 1.0 (25 mm) and Y 1.0 (25 mm), and 

click Next. 

This displays the Strategies page. This page controls the types of opera-

tions used to cut the feature. The default operations for a Hole feature are to spot 

drill and then drill the hole. If the Hole has a chamfer, the default is to cut the 

chamfer with the spot drill operation.  
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− Accept the default strategy settings by clicking Next. 

The Operations page shows a summary of the operations to cut the fea-

ture, the automatically selected tools, and the feeds and speeds. 

 

From the Finish menu button select the Finish  option. 

 

2. Create a Rectangular Pocket feature. 

− Click the Features  step in the Steps panel. 

− In the New Feature wizard, in the From Dimensions section, select 

Rectangular Pocket, and click Next. 

− Accept the default dimensions by clicking Next. 

− Enter a pocket location of X 0.75 (15 mm), and Y 2.5 (60 mm), and Z 

0 (0 mm), and click Next. 

− Enter a pocket location of X 0.75 (15 mm), and Y 2.5 (60 mm), and Z 

0 (0 mm), and click Next. 
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− Click the Finish button. 

3. Use the Features  step to create a second Hole with a diameter of 

0.5 (12 mm), located at X=4 (95 mm) and Y=3 (75 mm). 

4. Use the Features , step to create another Rectangular Pocket the 

same dimensions as the first, but positioned at X=2.5 (55 mm), Y=0.5 (15 mm). 

 

5. Select File > Save, and save the part as milling.fm. 
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3.2.3. Viewing the part 

To look at the part in a different orientation you can select one of the 

standard predefined views. These options are available from the Standard 

toolbar: 

 

To change the view to an isometric view, click the Isometric  button on 

the Standard toolbar. 

 

2. To change the view to a front view, from the Principle View  menu 

button, click the Front  button. 
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3 Click the Isometric  button to return to the isometric view. 

3.2.4. Simulating the toolpaths 

Now you have created the features, FeatureCAM automatically. Selects 

the most appropriate tools and operations; Recommends machining strategies; 

Calculates speeds and feeds; Generates toolpaths and creates the NC code. 

To view the simulated toolpath: 

1. Click the Toolpaths  step in the Steps panel todisplay the Simula-

tion toolbar. 

 

2. On the Simulation toolbar, select the 3D Simulation , option, and 

then click Play  to start the simulation. If the Automatic Ordering Options di-

alog displays, click OK to close it. This accepts the default ordering options. 

This displays a solid 3D rendering of the cutting process. 
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✓ If all tools are displayed in gray in the simulation, select Options > Sim-

ulation > General from the menu, and select the Tool Colors option, 

then click OK to close the dialog. This displays tools in different colors 

so you can see which features are machined by each tool. Click the Play 

 button on the Simulation toolbar to see the changes. 

3. Click the Play to Next Operation  button. This displays the spot drill 

operation. 

 

4. Repeat step 3 to view each subsequent operation until you complete the 

simulation. 

5. Click Eject . This removes the Simulation toolbar. 

3.2.5. Order of manufacturing operations 

The Op List tab in the Results window shows all of the operations needed 

to machine the features. A yellow warning sign next to an operation indicates a 

potential problem with that operation. In this case, if you see any warnings ig-

nore them. 
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3.2.5.1 Automatic ordering operations 

You can control the automatic ordering of operations by using either rules 

or operation templates. The turning tutorial looks at operation templates. 

1. Select the Automatic Ordering option on the Op List tab. This ensures 

the automatic ordering rules are applied to the operations. 

2. Change the automatic ordering to group together the operations which 

use the same tool. 

− Click the Ordering Options  button. 

− In the Automatic Ordering Options dialog, select Minimize tool 

changes, deselect everything else, and click OK. 

 

3. Simulate the part. 

− Select the Toolpaths  step from the Steps panel. This displays the 

Simulation toolbar. 
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− Click the 3D Simulation  button. 

− Click the Play  button. 

If the Automatic Ordering Options dialog displays, click OK to close it. 

Notice that the simulation first performs all the spot-drills, then the drills, and 

then the rough and finish milling for the pockets. 

− Click the Stop button when simulation is complete to exit the simula-

tion mode. 

4. Change the automatic ordering to move the finish operations to the end 

of the list. 

− Click the Ordering Options  button. 

− In the Automatic Ordering Options dialog, select Do finish cuts last, 

deselect everything else, and click OK. 

 

This changes the order of operations in the Operation List. 

5. Simulate the part. 

− In the Simulation toolbar, click Play . The finish cuts for the two 

pockets are now cut last. 

− Click Stop  when simulation is complete. 

6. Change the automatic ordering to match the order of the features in the 

Part View panel. 

− Click the Ordering Options  button. 

− Deselect everything, and click OK.  

− Open the Part View panel by clicking on . The 

tree view contains all the setups and features you have created. 
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− Click the rect_pock2 item in the Setup1 node, and drag it up above 

hole2. 

 

7. Simulate the part. 

− In the Simulation toolbar, click Play . The second pocket is cut as 

the second feature. 

− Click Stop . 

3.2.5.2 Manual ordering options 

The automatic ordering of operations determined the order by a set of 

rules. You can also specify an exact ordering of operations manually. 

1. Select the Manual Ordering option on the Op List tab. 

2. In the Fixed Operation Ordering dialog, select Do Not Show This 

Warning Again, and click OK. 

 

3. Select the spotdrill operation for hole2 from the list, and drag it up 

ahead of the drill operation for hole1. 



58 

 

4. Simulate the part. 

− In the Simulation toolbar, click Play . The simulation performs the 

operations in the new order. 

− Click Stop , when simulation is complete. 

5. Selecting Automatic Ordering to return to automatic ordering. 

6. Click OK to close the Automatic Operation Ordering dialog.  

✓ If you want to erase the simulation and remove the Simulation toolbar, 

click Eject . 

3.2.6. Part documentation 

As well as simulating the part manufacture, the simulation generates tool 

and operation lists. The tools selected are based on your tool database. You can 

print this information to use as an operator's checklist, using the File > Print 

menu option. 

Click the Details tab in the Results window to display the Manufacturing 

Operations sheet. 
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2. Select the Tool List option at the top of the Details tab to show the 

Manufacturing Tool Detail sheet. It contains all of the tools used to create the 

part based on the tool crib you selected. 

 

3.2.7. Controlling the strategies 
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You can control the strategies used to manufacture the part from the prop-

erties dialog. 

1. Open the Part View panel. 

2. Right-click on hole1 under the Setup1 node, and select the Properties 

option. 

 

3. In the Properties dialog: 

 

− Select the Strategy tab 

− Deselect the Spot Drill option 

− Click OK. 

4. Select the Toolpaths  step from the Steps panel. 
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5. In the Simulation toolbar, click the 3D Simulation , button, and then 

click Play  to start the simulation. 

✓ There is no spot drilling for the first hole. If you look through the opera-

tions list, there is only one spotdrill operation listed. FeatureCAM opti-

mizes the part manufacturing process, but you control the level of auto-

matic optimization. 

6. Click Eject . This removes the Simulation toolbar. 

3.2.8. Generating NC code 

FeatureCAM generates the NC code to manufacture parts on a CNC ma-

chine. You can generate NC code after you have simulated the part, and there-

fore calculated the toolpaths. 

1. Select the NC Code  step from the Steps panel. This displays the 

NC Code dialog. 

2. Click the NC Program  button to generate the code. 
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3.9. Tool mapping 

To change the location of the tools in the tool changer: 

1. Select the NC Code  step from the Steps panel. This displays the 

NC Code dialog.  

2. Click the Tool Mapping  button. This displays the Tool Mapping 

showing the current tool order. 

 

3. To move the center drill to the 5th position in the tool changer: 

− Select Center_5 in the table. 

− Enter a Tool Number of 5 in the Slots frame. 

− Click Set. 

✓ You cannot change the number in the table. 

4. Click OK to save the changes, and close the Tool Mapping dialog. 

3.2.10. Saving the NC code 

Для збереження керуючої програми: 
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1. Select the NC Code  step from the Steps panel. This displays the 

NC Code dialog. 

2. Click the Save NC  button in the NC Code dialog. 

3. In the Save NC dialog, accept the default filename and folder, and click 

OK. 

 

3.3 Tasks for the laboratory session 

According to the individual option, in the Delcam FeatureCAM system, 

create the necessary elements of milling processing, determine the list and se-

quence of the operation, and generate the control program code for the CNC 

machine. 

The main goal of this task is to study the commands of the "Elements" 

tool panel for milling operations. In the process of performing the work, the stu-

dent must learn to manage the strategy of processing certain elements, change 



64 

the order of operations and the location of the tool, manage the auto-

arrangement options. Know and be able to create milling elements and arrays 

based on them. 

Variants of tasks are given in Appendix C, p. 96. 

3.4 Requirements for a report on the performance of a laboratory 

session 

The report should contain the following sections: 

1. Topic and purpose. 

2. Individual task. 

3. Development of a control program for milling processing: 

− appearance and dimensions of the workpiece; 

− elements and contours for generating the control program; 

− operations and their main characteristics; 

− control program code; 

− part model. 

4. Conclusions from the laboratory session. 

3.5 Control questions 

1. What milling elements can be created without first creating contours. 

2. Purpose and features of using elements: wall, ledge, groove, pocket. 

3. Describe the methods of changing the order of operations. 

4. Auto setting options. 

5. Management of processing strategies. 

6. Justify the necessity and method of changing the postprocessor. 

7. How to get information about the project. 

8. Methods of saving the control program code. 
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LABORATORY LESSON №4 

3.5D MILLING IN DELCAM FEATURECAM 

4.1 Goal 

Familiarize yourself with the technique of creating different types of 

surfaces in the DELCAM FeatureCAM system. Learn to create control pro-

grams for processing complex surfaces. 

4.2 An example of creating a typical 3.5D milling part 

This example introduces students to the method of 3D surface modeling 

and their processing using surface milling elements. Definition of processing 

operations and their attributes. 

Entering the system and setting the initial parameters is carried out ac-

cording to the methodology given in laboratory work No. 1, however, as the 

type of processing, you must select Milling, the units of measurement are inch-

es. 

4.2.1. Defining the Stock 

The stock is the initial material from which you cut your part. 

1. On the Dimensions page of the Stock wizard: 
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− Enter a Thickness of 2. 

− Enter a Width of 3. 

− Enter a Length of 6.25. 

− Click Finish. 

2. Click OK to accept the default values of the Stock Properties dialog. 

4.2.2. Defining the geometry 

This shows you how to design your part. 

 

1. Select View > Toolbars from the menu, in the Toolbars frame: 

− Select Advanced. 

− Select Geometry. 

− Click OK. 

2. Create three vertical lines 

− On the Geometry toolbar, select Vertical  from the Line  

menu. 
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− In the Feature/Geometry Edit bar, enter an XYZ of X 1, Z 0, and press 

Enter. 

− Create a second line by entering an XYZ of X 5.25, Z 0, and press En-

ter. 

− Create a third line by entering an XYZ of X 6, Z 0, and press Enter. 

 

3. Create three horizontal lines:  

− On the Geometry toolbar, select Horizontal  from the Line  

menu.  

− Enter an XYZ of Y 0.5, Z 0, and press Enter.  

− Create a second line by entering an XYZ of Y 1.125, Z 0, and press 

Enter.  

− Create a third line by entering an XYZ of Y 1.5, Z 0, and press Enter.  
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4. Create a through line:  

− On the Geometry toolbar, select Point, Angle  from the Line 

 menu.  

− In the Feature/Geometry Edit bar, enter an angle A of 30.  

− n the graphics window, click at the intersection between the second 

horizontal and second vertical lines, at point 1, to create a through line. 

 

5. Create arcs. 

On the Geometry toolbar, select 2 Pts, Radius  from the Arc  

menu. 

− In the Feature/Geometry Edit bar, enter a radius R of 0.5, and click the 

vertical line around point 2 and the horizontal line around point 3.  
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− Create the second arc: 

In the Feature/Geometry Edit bar, enter a radius R of 1.0, and click the 

horizontal line around point 4 and the through line around point 5. 

 

− Create the third arc by clicking the through line around point 6 and the 

horizontal line around point 7. 

 

6. To mill the part you need to chain the curves. 

− Select the Curves  step from the Steps panel.  

− In the Curves Creation dialog, select the Pick Curve Pieces  but-

ton. 

− Click at the intersection of the vertical and horizontal line at point 8 

and at the intersection of the vertical and horizontal line at point 9. 
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4.2.3. Creating the bottle surface 

1. Select the Surfaces  step from the Steps panel. 

2. In the Surface wizard, select Surface of Revolution, and click Next. 

 

3. On the Surface of Revolution page: 
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− Enter a Start Angle of 0. 

− Enter an End Angle of 180. 

− FeatureCAM automatically selects your chained curve in the Curve 

field. 

− In the Axis field, click the Pick line  button, and select the hori-

zontal line around point 1. 

 

Click Finish. 
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4.2.4. Viewing the part 

1. To change the view to an isometric view, click the Isometric  button 

on the Standard toolbar. 

 

2. Control how the part is displayed using the Viewing Options. 

− Select Options > Viewing from the menu. This displays the Viewing 

Options dialog. 

− Select the Show surface boundaries only option, and click Apply. 
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This displays the surfaces as only their outer boundaries and trimmed 

loops. No additional lines are drawn in the interior of the surface. This makes 

the display of larger models much faster. 

− Deselect the Show surface boundaries only option, and click Apply. 

This displays the surfaces with lines in the interior of the surface. This 

aids visualization, but for large models, it makes the display of the part slower. 

− Enter a Surface fineness Wireframe of 20, and click Apply. 

This displays the surfaces with more lines. Decreasing the value of Sur-

face Fineness improves the display quality but slows down the graphics. 

− Click OK to close the dialog 

3. From the Hide  menu on the Advanced toolbar, click the Hide All 

Geometry  button. 

4. From the Show  menu on the Advanced toolbar, click the Show 

all surfaces  button. 

5. Click the Shade  button, on the Standard toolbar, to shade the part. 
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4.2.5. Creating a surface milling feature 

This shows you how to create the surface features and select the toolpath 

strategies. 

1. On the Standard toolbar, click the Select  button, and select the sur-

face (srf1). On selection it turns red. 

 

2. Select the Features  step from the Steps panel.  
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3. In the New Feature wizard, in the From Surface frame, select the Sur-

face Milling option, and click next. 

4. On the Part Surface page click Next. 

5. On the New Strategy page, select the Choose Rough, Semi Finish, and 

Finish… option, and click Next. 

 

6. On the Rough page: 
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− Select the Z Level Rough option. 

− Select Classify slices as 3D Pocket. 

− Click Next. 

7. On the Semi-Finish page, select None, and click Next. 

 

8. On the Finish page, select Isoline. 

 

9. Click the Finish button. 
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4.2.6. Simulating the toolpaths 

To view the simulated toolpath: 

1. Click the Toolpaths step in the Steps panel todisplay the Simula-

tion toolbar.  

2. Click the 3D Simulation , button, and then click the Play  but-

ton to start the simulation. If the Automatic Ordering Options dialog displays, 

click OK to close it. This accepts the default ordering options. 

 

Note how the toolpaths are accurately simulated including the part rota-

tions. 

3. Click Eject . This removes the Simulation toolbar. 

4.3 Tasks for the laboratory session 

According to the individual option, in the Delcam FeatureCAM system, 

create the necessary elements of milling processing, determine the list and se-

quence of operations, and generate the control program code for the CNC ma-

chine. 

The main goal of this task is to study the auxiliary possibilities of creating 

geometry elements and methods of creating surfaces. In the process of perform-
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ing the work, the student must learn to create elements of surface treatment. Be 

able to adjust processing modes to achieve the required quality of the part. 

Variants of tasks are given in Appendix D, Art. 99. 

4.4 Requirements for a report on the performance of a laboratory 

session 

The report should contain the following sections: 

1. Topic and purpose. 

2. Individual task. 

3. Development of a control program for milling 3.5D processing: 

− appearance and dimensions of the workpiece; 

− elements and contours for generating the control program; 

− operations and their main characteristics; 

− control program code; 

− part model. 

4. Conclusions from the laboratory session. 

4.5 Control questions 

1. Features of creating vertical and horizontal lines. Geometry editing 

commands. Creating an ellipse and other complex contours. 

2. Describe methods for creating DELCAM FeatureCAM surfaces. 

3. Describe the method of creating a surface treatment element. 

4. Explain the features of use and the difference in surface treatment in the 

3D pocket and 3D protrusion modes. 

5. Explain the difference when using isoline, raster, and Z-level contour 

processing mode. 
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LABORATORY LESSON №5 

EDM IN DELCAM FEATURECAM 

5.1 Goal 

Explore the possibilities of the DELCAM FeatureCAM system when 

working in the EDM mode. Learn to create control programs for EDM. 

5.2 An example of creating a typical EDM part 

This example introduces students to the method of 3D surface modeling 

and their processing using surface milling elements. Definition of processing 

operations and their attributes. 

Entering the system and setting the initial parameters is carried out ac-

cording to the method given in laboratory work #1. Electroerosion operation 

should be selected as the type of processing, the units of measurement are inch-

es. As a blank, choose a block with a thickness of 0.5, a width of 4, and a length 

of 

4.5.2.1. Creating the profile 

This step defines the profile. 

 

1. Select the Curves  step from the Steps panel. 
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2. In the Curves Creation dialog, select the Curve Wizard  button. 

3. In the Curve Wizard:  

 

− Select a construction method of Other methods.  

− Select a constructor of Rectangle.  

− Click Next. 

4. On the Rectangle page:  

 

− Select Use corner, width, and height.  

− Enter corner point of 1, 1, 0. 
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− Enter a corner radius of 0.5.  

− Enter a Width of 2.0. 

− Enter a Height of 2.0.  

− Click Finish. 

5.2.2 Creating a wire EDM feature 

This shows you how to create a wire EDM feature. 

1. Click the Features  step in the Steps panel.  

2. In the New Feature wizard, select the Die option in the 2 Axis frame, 

and click Next.  

 

3. On the Curves page, click the Pick curve or geometry  button, select 

the curve you created, and click Next. 
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4. On the Location page, click Next.  

5. On the Dimensions page, enter a Thickness of 0.5 and click Next.  

6. On the Start page, click Next. 

7. On the Strategies page: 

 

− In the Operations field select Retract.  

− Select the Cutoff option.  

− Select the Contour option.  

− Click Finish. 

5.2.3. Simulating the wire EDM toolpath 

Now you have created the features, FeatureCAM automatically: 

− Selects the most appropriate tools and operations;   
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− Recommends machining strategies;  

− Calculates speeds and feeds;  

− Generates toolpaths and creates the NC code. 

To view the simulated toolpath: 

1. Click the Toolpaths  step in the Steps panel todisplay the Simula-

tion toolbar. 

 

2. Click the 2D Simulation  button on the Simulation toolbar.  

3. Center the Simulation Speed  slider to specify the simulation rate.  

4. From the Simulation Next  menu button, select the Play to Next 

Operation  button to see the retract operation. If the Automatic Ordering Op-

tions dialog displays, click OK to close it.  

✓ To slow down the simulation, drag the Simulation Speed  slider to the 

left.. 

 

5. Click the Play to Next Operation , button again to see the cutoff op-

eration.  
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6. Click the Play to Next Operation , button again to see the final con-

tour operation. 

 

7. Click Eject . 

5.2.4. Generating NC code 

FeatureCAM generates the NC code to manufacture parts on a CNC ma-

chine. You can generate NC code after you have simulated the part, and there-

fore calculated the toolpaths. 

1. Select the NC Code  step from the Steps panel. This displays the 

NC Code dialog. 

2. Click the Display the NC Code  button to generate the NC code. 
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5.2.5. Adding a taper angle 

This example shows you how to add a draft angle to a wire EDM part. 

 

1. Open the Part View panel, select the die1 feature from the Setup1 node, 

and click the Properties  button on the Feature/Geometry Edit toolbar. 

2. In the Properties dialog for die1: 

 

− Select Constant.  

− Select a taper type of Left.  
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− Enter a deg. of 10 as the taper angle. 

− Click Apply. 

3. Click the Hide Stock  button from the Hide  menu on the Ad-

vanced toolbar. 

 

4. Click the Isometric View  button on the Standard toolbar. 

 

5. Return back to the Properties dialog, set the taper type to Right, and 

click Apply.  

 

6. Change the taper type back to Left, and click OK to close the Properties 

dialog. 

7. Select the Toolpaths  step from the Steps panel.  

8. Click the 3D Simulation , button, and then click the Play  button.  

Since this is a matrix element, it is implied that the region in the middle of 

the curve will be removed. 
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9. Click the Select  button on the Standard toolbar. 

10. Click inside the curve. FeatureCAM deletes that part of the stock. 

 

11. Click Eject . 

12. From the Show  menu on the Advanced toolbar, click the Show 

Stock  button. 

5.3 Tasks for the laboratory session 

According to the individual option, in the Delcam FeatureCAM system, 

create the contour of the EDM part. 

The main goal of this task is to study various methods of creating con-

tours, including standard curves. To study the peculiarities of creating EEO ele-

ments, to determine the main differences when creating elements of the "Pan-
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son" and "Matrix" type. Be able to set up simulation of part processing and gen-

erate control program code, as well as remove redundant elements after pro-

cessing. 

Variants of tasks are given in Appendix E, Art. 103 

5.4 Requirements for a report on the performance of a laboratory 

session 

The report should contain the following sections: 

1. Topic and purpose. 

2. Individual task. 

3. Development of a control program for EDM: 

− appearance and dimensions of the workpiece; 

− elements and contours for generating the control program; 

− operations and their main characteristics; 

− control program code; 

− part model. 

4. Conclusions from the laboratory session. 

5.5 Control questions 

1. Describe the possible options for creating DELCAM FeatureCAM con-

tours. 

2. Explain the features of creating EEO elements of the "Punch" and "Ma-

trix" type. 

3. Determine the need to create slopes for details, explain the specifics of 

the team's work. 

4. Determine the methods of detail display, describe the sequence of hid-

ing unnecessary elements. 
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ADDITION А 

Variants of tasks for laboratory work №1 

Develop a turning program for a CNC machine tool. 

Workpiece: cylinder 180 mm long, 90 mm in diameter. 

Processing on the outer diameter of the largest step should not be provid-

ed, the end processing should be carried out with an allowance of 1.5 mm. 
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1 20 55 75 85 22 40 70 90 20 2 4 4 6 

4 25 45 80 90 24 50 75 90 22 2 3 3 5 

7 20 50 70 80 26 60 80 90 24 3 4 5 2 

10 15 60 75 80 24 45 75 90 22 3 3 3 4 

13 25 50 70 70 22 55 80 90 20 4 4 4 3 
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Develop a turning program for a CNC machine tool. 

Workpiece: cylinder 200 mm long, 100 mm in diameter. 

Processing on the outer diameter of the largest step should not be provid-

ed, the end processing should be carried out with an allowance of 2 mm. 
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11 30 65 70 45 69 72 60 72 100 50 54 38 2 6 4 

14 30 55 80 50 78 80 60 80 100 35 39 24 4 4 2 
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Develop a turning program for a CNC machine tool. 

Workpiece: cylinder 180 mm long, 80 mm in diameter. 

Processing on the outer diameter of the largest step should not be provid-

ed, the end processing should be carried out with an allowance of 1 mm. 
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12 30 120 20 40 115 60 60 80 18 30 5 5 2 3 

15 35 110 15 30 90 55 55 80 20 28 6 2 2 4 
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ADDITION B 

Variants of tasks for laboratory work №2 

Develop a turning and milling program for a CNC machine tool. 

The dimensions of the workpiece and the size of the end allowance are 

shown in the figure with a dashed line. 

The format and size of the font, as well as the angle of inclination of the 

text line, must be chosen arbitrarily, provided that the end surface of the part is 

most rationally filled. That is, when creating a test line, it is necessary to avoid 

the intersection of the text with holes, as well as to choose the font size and its 

scale in such a way as to obtain the largest text font. 
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Develop a turning and milling program for a CNC machine tool. 

The dimensions of the workpiece and the size of the end allowance are 

shown in the figure with a dashed line. 

The format and size of the font, as well as the angle of inclination of the 

text line, must be chosen arbitrarily, provided that the end surface of the part is 

most rationally filled. That is, when creating a test line, it is necessary to avoid 

the intersection of the text with holes, as well as to choose the font size and its 

scale in such a way as to obtain the largest text font. 
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Develop a turning and milling program for a CNC machine tool. 

The dimensions of the workpiece and the size of the end allowance are 

shown in the figure with a dashed line. 

The format and size of the font, as well as the angle of inclination of the 

text line, must be chosen arbitrarily, provided that the end surface of the part is 

most rationally filled. That is, when creating a test line, it is necessary to avoid 

the intersection of the text with holes, as well as to choose the font size and its 

scale in such a way as to obtain the largest text font. 
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ADDITION C 

Variants of tasks for laboratory work №3 

Develop a milling program for a CNC machine tool. 

The dimensions and shape of the workpiece should be chosen from the 

condition of ensuring the necessary parameters of the part. Processing along the 

outer contour is not expected. Processing of the upper flat surface should be car-

ried out with an allowance of 2 mm. 
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Develop a milling program for a CNC machine tool. 

The dimensions and shape of the workpiece should be chosen from the 

condition of ensuring the necessary parameters of the part. Processing along the 

outer contour is not expected. Processing of the upper flat surface should be car-

ried out with an allowance of 2 mm. 
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Develop a milling program for a CNC machine tool. 

The dimensions and shape of the workpiece should be chosen from the 

condition of ensuring the necessary parameters of the part. Processing along the 

outer contour is not expected. Processing of the upper flat surface should be car-

ried out with an allowance of 2 mm. 
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ADDITION D 

Variants of tasks for laboratory work №4 

Create a foundry mold for the production of a three-dimensional chess 

figure. The length and width of the workpiece are indicated in the figure, the 

height should be chosen equal to half the width. 
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Create a foundry mold for the production of a three-dimensional chess 

figure. The length and width of the workpiece are indicated in the figure, the 

height should be chosen equal to half the width. 
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Create a foundry mold for the production of a three-dimensional chess 

figure. The length and width of the workpiece are indicated in the figure, the 

height should be chosen equal to half the width. 
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Create a foundry mold for the production of a three-dimensional chess 

figure. The length and width of the workpiece are indicated in the figure, the 

height should be chosen equal to half the width. 
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ADDITION E 

Variants of tasks for laboratory work №5 

The length and width of the workpiece are indicated by a dashed line, the 

thickness is individual for each variant. 

 
1 Create a matrix of the depicted 

form. The thickness of the work-

piece5 mm. 

Angle: left, 50. 

2 Create a punch of the shown 

shape. The thickness of the 

workpiece5 mm. 

Angle: right, 50. 

 
3 Create a matrix of the depicted 

form. The thickness of the work-

piece7 mm. 

Angle: left, 70. 

4 Create a punch of the shown 

shape. The thickness of the 

workpiece7 mm. 

Angle: right, 70. 
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5 Create a matrix of the depicted 

form. The thickness of the work-

piece10 mm. 

Angle: left, 50. 

6 Create a punch of the shown 

shape. The thickness of the 

workpiece10 mm. 

Angle: right, 50. 

 
7 Create a matrix of the depicted 

form. The thickness of the work-

piece10 mm. 

Angle: left, 100. 

8 Create a punch of the shown 

shape. The thickness of the 

workpiece10 mm. 

Angle: right, 100. 
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9 Create a matrix of the depicted 

form. The thickness of the work-

piece5 mm. 

Angle: left, 100. 

10 Create a punch of the shown 

shape. The thickness of the 

workpiece5 mm. 

Angle: right, 100. 

 
11 Create a matrix of the depicted 

form. The thickness of the work-

piece7 mm. 

Angle: left, 100. 

12 Create a punch of the shown 

shape. The thickness of the 

workpiece7 mm. 

Angle: right, 100. 
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13 Create a matrix of the depicted 

form. The thickness of the work-

piece10 mm. 

Angle: left, 70. 

14 Create a punch of the shown 

shape. The thickness of the 

workpiece10 mm. 

Angle: right, 70. 

 
15 Create a matrix of the depicted 

form. The thickness of the work-

piece8 mm. 

Angle: left, 100. 

16 Create a punch of the shown 

shape. The thickness of the 

workpiece8 mm. 

Angle: right, 100. 
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